Jump to content
  • Similar Content

    • By Andi
      Hey folks that are patiently, or impatiently, awaiting a shipping notice or bike, please read this. Based on our experience with this since 2015, here is what you can expect:  PLUS, the Pandemic has a huge affect on deliveries with overcapacity UPS capabilities.  
      As containers arrive in LA, UPS take possession and gets them processed through customs. There are hundreds of bikes per container, and probably a dozen containers.  As each container is opened, UPS will mark them as received and you may get a notice with an expected delivery date (either from UPS or Sondors). This does not necessarily mean that it is on a truck yet or has left the facility The bikes are shipped by truck, not air. Once it leaves LA you may not get any update for days as the truck works it's way to your regional or local hub where it will be offloaded and scanned again. Not getting an update for a few days is normal. You will sometimes get a planned delivery notice once it gets to your local UPS. However, sometimes it just shows on your doorstep. Sometimes it shows up on your doorstep when the tracking shows that it's still in LA. It's quite inconsistent, and nobody should panic. If you get a notice, be patient. It can take more than 2 weeks to get to you depending on how fast they empty the containers and when they find space in a truck, how long the drive is, etc. Signing up for UPS My Choice might give you more info, but sometimes not. Whatever you do, don't start bombarding Sondors with emails about "where is my bike" yet. They have probably opened 1 of a dozen containers so far and are working through things over the next couple of weeks We all know there's a huge shipment of bikes coming. Thousands of bikes. I can feel the excitement, or maybe it's just me lol. But anyway I can feel the pressure building. We don't mind you posting your delivery notice, but please don't post your tracking number. Just black that part out, and you're good to go. You don't want anyone the be able to reroute your delivery to my house do you? Moderators will delete all posts we see with tracking numbers. If you have ordered or already got your Sondors eBike - please login or register and pin yourself to the member map: https://sondorsforum.com/membermap/
      If you have not received your bike yet and still want a test ride or meet Storm Sondors? Check out this Event:
       
      Feel free to post your unpacked or still packed bike in this Gallery Section - We are looking forward to your pictures!
      https://sondorsforum.com/gallery/category/3-unboxed-show-us-your-sondors-ebike/
       
      The Sondors Owner Forum is a great place to share information about your Sondors eBike. We have many available resources here, that may have great value for you. Take your time and read everything carefully. I would love to see you as an new member on the Owners Forum! Questions? Feel free to ask!
       
       
    • By DinoPizzaJamz
      Long time listener, first time caller here 
      So I will try to keep this short...
      Bought a used fatty a year ago and it sat in storage for a bit over winter... I took it out and tried to move it, and the rear wheel was locked up and wouldn’t go backwards.. Have been poring over this page and the Facebook page  and I’ve gotten pretty far but now I need some advice
      I’ve replaced the throttle (the button was broken so was needed), and upgraded the controller (it came with the bike so I figured why not while I’m at it...) I didn’t think those were really solutions, so no surprise when that wasn’t a fix.
      Ao now the throttle works.  I press down, the voltage is reading in the lcd and I can hear a “click” in the motor. But no response/movement otherwise.... 
      am I correct in assuming this is a motor issue? Have checked all cable connections and they are good.  Tested the battery, it read at 38 when off and went up to 40/41 when on... so seems like battery is good...
      I thought I might take it apart and check, the Luna motor instructions made it seem like a simple 3 step  easy removal.. so I finally removed the rear wheel and then got to “Remove the sprocket...”
      I’ve read everywhere that removing the sprocket will destroy it soooo... before I destroy my sprocket and take apart my motor... are there any other issues I could check?? Or am I right in assuming it’s a motor issue?
       
      the sprocket is pretty rusty... there’s a good amount of rust in places there probably shouldn’t be rust....  I have some simple green cleaner/degreaser but would really appreciate  some advice on  removing  rust tooo!!
      And I guess while I’m here, and if it’s needed, can anyone recommend a good replacement sprocket/motor?? Is luna good, despite their instructions are not so simple as they seem?  what confuses me is that they don’t think you will need a new sprocket, or is that included?
      Thanks for listening y’all, hopefully my bike isn’t a total lost cause...
    • By SportFoldBoy420
      My lcd has just died on my Fold sport from water damage I'm quite sure so this is my perfect opportunity to upgrade I have been looking at the 750w bafang rear hub motor and they say it will lace in 350w motor no problem but I have the 250w bafang rear hub motor. Will it fit? But first I want too upgrade the sondors lcd to the ktc3 25 amp and 25 amp controller and will wait till sondors have the 48v 14 amp available in Europe  until i upgrade the motor as the 38v 8.8amp battery won't be powerful enough. Any suggestions or problems with my plan I would appreciate feed back
    • By Lane
      Hello everyone, I currently have an Original Sondors Fat Tire bike from 2016 (I believe).  I purchased it from a friend who had performed some upgrades to it.
      As the bike sits today:
      Luna Storm 48v 20ah Battery Controller Model KT36/48ZWSRMD-SLSLD02 Rated for DC 36v or 48v, Rated current 12A Maximum current 25+-1A (Assuming this is from Luna as well) Original Motor Bafang RMG06 36v 350W(10) 26-1-1508195560-6 LCD Luna LCD Dashboard for Sondors KT-LCD3 Took the bike out for a ride the other day after it had been sitting in the garage for about a month and received a motor hall connection error on my LCD screen. Tried the usual unplugging the connection under the chainstay and making sure I had charged the battery. I'm wondering if I am able to replace the cable coming out of my motor (if that is the culprit) or if I need to replace the motor altogether. If that is the case, would anyone recommend I upgrade to a 48v motor? Would it make a difference/ work with my existing upgrades? I'm new to the forum and Ebike scene in general so I appreciate any help. Thanks!
  • Popular Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use and Privacy Policy.