Jump to content

Recommended Posts

I have a new XS, shipped NIB to me in August.  I have approximately 300 miles on this bike.  I'm experiencing erratic power output to the motor through the color LCD display.  With factory default settings, here is what is happening:  While riding the bike after initial turn on, power assist level 5, the bike easily reaches top speed, between 21 and 22 mph.  While keeping constant pedal speed, after about 0.2 miles, power output to the motor is gradually is reduced, to the point that I cannot maintain top speed.  Power to the motor is reduced and I will slow to 13-15 mph.  While this is happening, if I change to power assist level 3, I get an immediate boost of power to the motor and I can regain top speed.  Then, the bike seems to figure out that is should be in power assist level 3 and it will slow down again.  At this point if I change to power assist level 5, I will regain speed again.  I can every time this happens I can change power assist level and it seems to reset - the cycle continues over and over.

I have contacted tech support and Sondors has been great so far.  First we checked out the PAS sensor and this seems to be working fine.  One of the techs asked me to unplug the screen and use the plug the bike was shipped with.  When this plug is used instead of the color LCD screen, the erratic power problem goes away.  We thought this meant the Color LCD was defective.  Sondors sent me a new one and I installed it - and the new one acts the same way.  If I can't get the bike fixed, I suppose I could ride it all the time with the plug instead of the LCD, but that seems silly.  The bike also doesn't accelerate with the plug as well as it accelerates with the LCD installed.

I'm reaching out on the forum - just wondering if anyone else has the same issue or has heard of this happening.  This XS is the 3rd Sondors in my fleet of Ebikes.  I have so much fun with Ebiking on trails near my home I wanted to get a few more bikes so I can share the experience with friends.  When the motor starts pushing - it brings a smile to everyone's face that rides.  The problem with this erratic power issue is that it makes speed control for 3 riders kind of impossible.  One bike just randomly starts slowing down and there is no way to effort your way back to 21 mph.  This problem makes group riding a bit of a challenge and not as fun as it should be.

Today I tested different settings on the display.  The Sondors tech suggested that I change the max speed to 25 mph, so I did that.  The same "slowdown" took place with this setting - except it went from 25mph to 18.  Same fix worked, change to assist level 3, fixed it then that slows down, go back to 5, repeat.  I then changed the max current from 25 to 30.  Same thing happens - except this seems to eat the battery, I changed it back to 25A.  I switched the power assist mode to 3 levels, same thing happens.

I think there is some kind of software glitch with settings, but on the other hand, maybe something wrong with the motor controller?  Does anyone have ideas of what could cause this?  

I'm attaching a video so you can see and hear what is happening.




Link to post
Share on other sites

I’ve got the same issue.  Mine will regain full power If I go to pas 4.   I’ve notified sondors about the issue and awaiting some insight.   Mine will also intermittently cut power during full throttle mode at max speed, at this time pas or throttle will not work until the bike slows to under 17mph then power is restored.   My temporary fix right now is I reset the pas percentages so that pas 4 and 5 are maxed out.  Planning on just using pas 4 for my max speed and not using pas 5.  Haven’t ridden yet since messing with the pas percentages.  

Link to post
Share on other sites

Sinister_xs I have also experienced the throttle cut out.  This happens when I'm going uphill and me and the bike cannot maintain speed.  On my other bikes all is fine, me and bike both give full effort and we slow down a little while going up, once we crest the hill we speed up to max and then the bike can relax a little.  I can see the bike's power (effort) on my older bikes and when we are maxed out it maxes at between 500 and 600 Watts depending on the state of battery charge.  On my new bike the power is almost cut off completely, it acts like it just gives up.  

Mine does not regain full power at pas 4, but it does regain some power at that level.  When I shift to pas 3 I do get full power.

I changed settings on the color display to only use pas 1-3.  Same power cutoff happened in this mode as well.  Let me know how resetting your pas % to max at 4 works out or if you discover a setting workaround for this issue.  

Yesterday I did 26 miles on the trail without the display (used plug only), and the bike was very consistent with speed.  No cutoff detected by me.  This is why I'm doubting the controller is the root cause.  I still suspect some kind of software glitch between the display and the controller - but I'm open to try anything.


Link to post
Share on other sites
On 10/18/2020 at 3:57 PM, Tim Rosengarten said:

David, do you know of a way to troubleshoot the issue without swapping out the part?


We have a test kit in our shop like the one in the Web site I have you. These are cheap and test motor throttle and a couple other things. We have one in our shop. Give this a read hopeful it will help.    https://fatwoody.com/troubleshooting-022

Link to post
Share on other sites

Sounds like to me that these higher current demands are pushing the controller into clipping. Im not sure why that’s happening with a controller that the engineers selected for that bike. Might be a bad production run of controllers, we had that on the early Folds and you are the second to report a similar issue.  I’d also consider that the battery’s BMS could limit output, at the higher demands, if it was lowering the capacity of the battery past limits. 
A good quality watt meter between the controller and motor (nightmare to install) and between the battery and controller might help diagnose the power delivery conundrum. But you’ll have to wait for Sondors to take action. We don’t replace parts. 
‘I’m betting they send you a new controller, in the past it’s the most unreliable of the reliable components ... my controller has over 17,000 miles. Go Figger



Link to post
Share on other sites

Reddy Kilowatt - and Sinister_xs - thank you both for the replies.  I'm working through the issue with Sondors Tech support and we are moving onto the controller as the next likely cause of the issue.  Sondors has been very responsive on this issue and I am very happy we are still troubleshooting what the issues is.  I'll post the results of what happens next.  Still loving my ebikes and the XS is awesome - I know we will figure it out.  Thanks for helping!

Link to post
Share on other sites

Tim, what is your factory date on your controller?  Mine is 07/2020.  Wondering if they are the same batch.   I have yet to hear from sondors tech support via email, but plan on contacting them tomorrow via chat.   I’m just hoping if it is the controller that they have some in stock and are able to get a replacement ASAP.  

Edited by Sinister_xs
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By didi
      Speed and power limit with new motor
      Hi dear Sondors community,
      I am experiencing a very strange problem concerning the speed limit on my Sondors Custom 350 watt 36 volt fatbike. Since neither me nor the Luna Cycle support was able to figure out what the reason for this problem could be, I hope that maybe somebody in this forum can help me with this issue!
      The situation is the following:
      I have two Sondors Custom 350 watt fatbikes, both are equipped with the Luna Cycle KT LCD3 Display and the Hot Rod 20 amp controller, both worked fine and top speed was approximantely 25 mph. one of them at one point had a motor damage, therefore I ordered a new motor from Ebay and installed it succesfully. It should be the same Bafang 350 watt motor, just the axle is slightly broader, the wattage and volts are the same after installing the new motor (and despite checking the recommended KT-LCD3 settings like 20 times) this fatbike with the new motor had a speed limit of approximately 18 mph which seems to be impossible to remove since I switched both, the controller and the KT-LCD3 Display, from one bike to the other to check which component could be causing this problem, I am pretty sure that these components are working fine. But the bike with the new motor is limited in speed and max wattage no matter what I do. I was told, that the Display is responsible for the speed limit, but since I've tried to switch Displays, it seems impossible to me that this could be the cause for this problem.
      Anybody has an idea how I could remove this speed limit?
      Thank you very much folks!
      For those interested, I attach the conversation I had with Luna Cycle trying to figure out what the poblem is, they suggested to ask the Sondors forum for help since neither they knew what issue could be the reason for this strange limit.
    • By Andi
      written by Mike Ritchie – B/Y Storm e-bike owner
      Here are a few pictures showing the "no power" issue caused by a brake switch being
      triggered. If you've charged your battery, inserted it correctly and have your battery
      switch turn to "on", and you confirm that the LED lights on your handlebar throttle
      illuminate, BUT you don't get power (or intermittent power) the issue is likely with your
      brake cutout switch. This bike is designed to cut off the motor when the brake levers are
      depressed, even a very small amount. This issue can be caused by brake cables with
      too much slack, creating play in the brake lever.

      In this first picture you can see a properly
      aligned brake with no slack. The lever is
      fully released and there is no gap between
      it and the housing. This is how things
      should look.

      In this second shot I have depressed the
      lever ever so slightly. I'm doing this manually,
      but this can also be caused by slack. The
      brake cable should be tight enough that this
      doesn't happen due to just being loose. A
      gap this small will cause your power to cut

      Here's what happened to me. I had things
      installed correctly, but I didn't notice that the
      brake cable itself found its way to a position
      where it kept the brake lever from fully
      releasing. Once I read that the brakes could do
      this (thanks guys) I quickly found the issue. My
      cable is now out of the way and snapped to
      other cables to keep it that way. Hope this all
    • By Coastie
      Assist mode - pulse or constant?
      I have 2 original eBikes with LCD, the first one (my girlfriend's) assist mode pulses - so as she pedals steadily the assist pulses on, then off, then on, then off - automatically.
      On my ebike that came in a few months later my assist mode is constant - it doesn't pulse.  As I pedal steadily the motor constantly assists, which seems like it would discharge the battery faster.
      Which is the correct assist mode and how do I change between pulse and constant?
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use and Privacy Policy.