Jump to content
p0tty

Tried to upgrade a fold x 35a 750w 52v and only 4mph

Recommended Posts

I got a 35a controller, a 750w motor, and a 52v battery and it only hits 4mph. I tried it with the original condors 48v battery and get 3.7mph.

I put the 25a controller and the 500w motor back in and hit 26mph with the 48v battery and 28mph with the 52v battery.

I am unable to test the 25a controller with the 750w motor and the 35a with the 500w motor because the pins in the motor cables differ.

Does anyone else have a 35a controller setup?

Share this post


Link to post
Share on other sites

So I talked to them at passion bike and they were little help, probably a language barrier. They said to send the controller to Kyle at Bolton Ebikes (sierra ebikes etc) and have him test it.

I decided to shoot them an email over at Bolton Ebikes before wasting money on shipping, didn't talk to Kyle but the person who replied to my email suggested changing the p2 setting to 5, and it worked.

28.8mph!!

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use and Privacy Policy.