Jump to content

HELP! Sondors Ebike Won't Start


Recommended Posts

The LED brake symbol )O( is on, which people said is why the Sondors Ebike won't turn on. When I disconnect the rear brake red electrical wire to the computer, it does start and can ride.

5ac7ef8d1ea2572f3a17b5fd4d016a9d.png

I thought the rear brake was maybe too tight so I removed the brake caliper. I then reconnected the red wire but the brake light LED still goes on and it won't start.

I also tried disconnected the brake wires from both front brake handle squeeze controls and the symbol still shows up.

What else can I try?

Edited by Arkitektual
Link to post
Share on other sites

@Arkitektual  I'd try some electric contact cleaner (Home Depot) in your brake lever mechanism and see if that might dislodge any tiny object or displaces any moisture. Replacement Sondors brake levers are avalable, I've seen them but not sure where. 

Try switching cables from brake levers to controller. It the front brake is now the one that tests bad, that would indicate a controller problem If it's still the rear lever.....you've got a bad rear lever or rear brake lever cable.

These might be a direct replacment.

http://www.greenbikekit.com/bafang-bbs01-bbs02-brake-grip-replacement.html

These mention Bafang 8Fun : https://www.empoweredcycles.com/products/8fun-bafang-bbs02-brake-levers-with-cut-off-switches

Andi (our compassionate and fearless leader) mentioned a generic fix for controller related problems that you could try. It's kinda like Hard Booting a computer : unplug the Battery to Controler cable and replug it. 

Lever trouble shooting video :

http://tinyurl.com/TableettersEBrakeLeverGuide

@Arkitektual

Link to post
Share on other sites

Hi @Arkitektual,

first of all, welcome to the forum. Nice to see you here :) 

Please check the following topic: 

 

15 hours ago, Arkitektual said:

When I disconnect the rear brake red electrical wire to the computer, it does start and can ride.

This looks to me like a faulty sensor, the question is, it is caused by the brake lever or the controller. 
Have you tried to clean the connections with a dust cleaning spray or something like this? Also I would recommend, to unplug everything from the controller and plug it back in, somehow that was often a problem solver. 

 

-Andi

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use and Privacy Policy.