Jump to content
We've updated some things - please give us feedback when something isn't working as it should. e-Mail: user-support@sondorsforum.com Read more... ×

Search the Community

Showing results for tags 'defective'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • SONDORS Forum
  • SONDORS - General
    • General Discussion
    • Introduce yourself!
  • SONDORS - Customization
    • Sondors eBike Accessories
    • Sondors eBikes & Parts | Marketplace
  • SONDORS - The Workbench
    • Q&A, Help & Troubleshooting
    • Instructions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. Hi all, So my girlfriend has a Sondors (fat tire) that she got a few months ago. Since then, I've run into this issue twice: the prongs in the battery compartment get stuck. See image below. I ordered a replacement part after the first time it happened, but not that it's happened again, this is starting to feel a bit ridiculous. Is this a known issue with any known fixes? I can't keep repairing/replacing this part. Note: this is not my image, this is from another user's post. But this is exactly what I'm seeing on her bike.
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use and Privacy Policy.