Jump to content

Mexica Quetzalcoatl

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Mexica Quetzalcoatl

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Does anybody have a picture of the hall sensor or an idea of where i can purchase one for the stock motor hub had same issue above trying to find the piece
  2. So i only had bike for a week, no burning smell, i did check PAS magnet and it was far apart im hoping that's it. Did all of the above that was mention. No water contact. havent had a chance to test but will update
  3. Oh and as i hit the throttle the lights go to yellow to red the more i press on it ... then when i let go it goes back to all lights lit up ... is that normal or should it always be all lit up if the battery is fully charged?
  4. I should add its a custom fat tire aluminium frame, no LCD I do have one but I moved and getting it sent to me since i left it at my old place. I also tried it without the brake connectors connected and again it work for a while and then just dies.
  5. I also had this problem and i took off both brake connectors and it work again but only for 10 minutes before cutting off, all lights are on , on the throttle controller .... im not sure but it seem to turn off when I hit a bump, any suggestions , anybody?
  6. throttle cuts off after 10 mintues I tested my Sondors bike and 10 minutes in the ride my sondors bike throttle stopped. I'd check battery and power cycle both the battery and throttle switch. The battery shows charged and throttle switch lights all the way green but no response what else can i check, wires seem fine as well. Check all connectors, no response from the pedal assist either. I tired it again in the morning and it work for about 10 minutes again and then stop working, not sure if it's due to a bad throttle control. I duno just use the throttle mostly, I wanted to see how long I could just use throttle until the battery dies. If i leave it alone for a while it just starts to work again the length of time I wait varies i check it every few hours and it works not sure whats going on.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use and Privacy Policy.