Jump to content

Q&A, Help & Troubleshooting

This forum is for all of your questions about the Sondors eBike. If you need help troubleshooting a problem, please be as specific as possible by describing your problem and any modifications you've done.

316 topics in this forum

    • 1 reply
    • 286 views
    • 9 replies
    • 930 views
  1. Battery Low Voltage

    • 4 replies
    • 488 views
    • 11 replies
    • 606 views
    • 1 reply
    • 760 views
    • 5 replies
    • 885 views
  2. Loose wires

    • 0 replies
    • 291 views
  3. Fold X 500WATT 48V 14Ah

    • 0 replies
    • 399 views
  4. Fold Handlebars Loose!

    • 17 replies
    • 1,279 views
  5. Nuts for Front Tire

    • 0 replies
    • 325 views
  6. New Fold X not working

    • 7 replies
    • 605 views
    • 3 replies
    • 570 views
    • 1 reply
    • 1,457 views
  7. 3" Tires on a Fold X

    • 2 replies
    • 871 views
    • 2 replies
    • 540 views
  8. No power

    • 8 replies
    • 409 views
    • 2 replies
    • 445 views
    • 3 replies
    • 514 views
  9. No pedal assist

    • 2 replies
    • 599 views
    • 12 replies
    • 1,251 views
    • 0 replies
    • 260 views
    • 1 reply
    • 445 views
    • 8 replies
    • 999 views
  10. Shipping Box

    • 4 replies
    • 937 views
    • 1 reply
    • 409 views


×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. By using this site, you agree to our Terms of Use and Privacy Policy.